Коды ошибок: STORAGE
| Код | Уровень | Что случилось | На что влияет | Как исправить | Обратить внимание |
|---|---|---|---|---|---|
#ERROR_KLVD_STORAGE_INIT_001 |
CRITICAL | каталог содержимого хранилища не открыт/не создан | роль хранения не стартует; запись писем невозможна | проверить путь CONTENT_DIR и права |
— |
#ERROR_KLVD_STORAGE_INIT_002 |
CRITICAL | SSL-сертификат не задан, но включён KLVD_STORAGE_FORCE_SSL |
роль хранения не стартует | предоставить сертификат (см. {{ССЫЛКА:maintenance.tls-rotate | TLS-сертификаты}}) или снять флаг |
#ERROR_KLVD_STORAGE_INIT_003 |
CRITICAL | не удалось запустить endpoint(!) (storage(!)/importer(!)) | узел не стартует | проверить занятость порта, конфигурацию | — |
#ERROR_KLVD_STORAGE_011 / _018 |
ERROR | чанк сохранён с деградированной избыточностью (меньше реплик, чем нужно) | данные в группе не имеют требуемого числа копий; возможна потеря данных при дальнейшем сбое | проверить состояние узлов группы; запустить перебалансировку | мониторить — деградация может привести к потере данных |
#WARN_KLVD_STORAGE_HEALTH_001 |
WARNING | повреждение: контрольная сумма блока на диске не совпадает | данные повреждены | будет запущено восстановление с соседнего узла (data-heal(!)) | требует избыточности группы > 1 |
#ERROR_KLVD_STORAGE_HEALTH_001 / _002 |
ERROR | критическая ошибка / ошибка блока при deep-health | проверка целостности не завершена | повторить deep-health | — |
#ERROR_KLVD_STORAGE_HEALTH_003 |
ERROR | не создана дочерняя задача deep-health | проверка не запущена | проверить планировщик | — |
#ERROR_KLVD_STORAGE_HEALTH_010 |
ERROR | опросщик здоровья группы провален | повтор через цикл | проверить БД | — |
#WARN_KLVD_STORAGE_HEALTH_002…004 |
WARNING | запросы здоровья группы провалены с резервное поведениеами | используется R=1 / предположение «не в группе» | проверить БД | — |
#ERROR_KLVD_STORAGE_HEALTH_011…014 |
ERROR | reverse-check (полнота по письмам): не удалось собрать хеши / нет storage(!)-клиента / построить цели / запросить presence | проверка полноты не выполнена | проверить БД и storage(!)-клиент | — |
#ERROR_KLVD_STORAGE_HEALTH_015 |
ERROR | безвозвратная потеря данных: чанки, на которые ссылаются письма/вложения группы, отсутствуют на всех узлах (нет ни одной копии) | затронутые письма/вложения нельзя восстановить | оповещение админу; хеши — в состоянии задачи (модалка, referenced.lost_hashes) |
data-heal(!) бессилен (копий нет) |
#WARN_KLVD_STORAGE_BULK_001…003 |
WARNING | bulk-CHECK (presence) к узлу провален (транспорт/HTTP/исключение) | узел пропущен в reverse-check (остальные проверены) | проверить доступность узла | — |
#WARN_KLVD_STORAGE_VERIFY_001…003 |
WARNING | /verify(!)-integrity к узлу провален (транспорт/HTTP/исключение) — координатор PG-driven deep-health |
узел пропущен (его статусы трактуются как missing при агрегации) | проверить доступность узла | — |
#WARN_KLVD_STORAGE_VERIFY_S3_001…002 |
WARNING | S3 HEAD/GET при integrity-проверке провален (транспорт/исключение) | объект трактуется как missing/corrupt при агрегации | проверить доступность S3, учётные данные, токены | — |
#WARN_KLVD_STORAGE_HEALTH_016 |
WARNING | PG-driven deep-health: нет active(!)-членов группы (некому проверять) | проверка не выполнена | добавить/включить узлы в группу | — |
#WARN_KLVD_INTEGRITY_001 / _002 |
WARNING | не удалось записать/закрыть проблему целостности в audit.integrity_issues (БД-ошибка) |
проблема не сохранена/не закрыта в журнале; сама проверка не пострадала | проверить БД | данные целы, только учёт |
#ERROR_KLVD_WUI_INTEGRITY_001 |
ERROR | ошибка выборки списка проблем целостности (/api/integrity/issues) |
раздел [Целостность] не загрузился | проверить БД; повторить | — |
#ERROR_KLVD_HEAL_001 |
ERROR | ошибка восстановления чанка | блок не восстановлен | проверить доступность соседних узлов | — |
#ERROR_KLVD_STORAGE_RETENTION_001 |
ERROR | задача очистки устаревших писем провалена | очистка не выполнена | повторить; проверить БД | — |
#ERROR_KLVD_STORAGE_RETRO_001 |
ERROR | ретроспективное применение правил провалено | — | повторить; проверить БД | — |
#ERROR_KLVD_REBALANCE_001 / _003 |
ERROR | ошибка чанка / backfill(!) при перебалансировке | перераспределение не завершено | повторить перебалансировку | — |
#ERROR_KLVD_REBALANCE_WATCH_001 |
ERROR | переход filling→active провален |
статус «требуется rebalance(!)» может остаться | повторить | — |
#WARN_KLVD_REBALANCE_WATCH_001 / _003 |
WARNING | запрос дерева наблюдения провален / перебалансировка завершена с ошибками | флаг is_rebalance_required остаётся |
повторить перебалансировку | — |
#WARN_KLVD_REBALANCE_WATCH_004 |
WARNING | rebalance(!) отменён (с ошибками); is_rebalance_required остаётся |
— | повторить | — |
#ERROR_KLVD_REBALANCE_WATCH_002 |
ERROR | drain(!): не удалось удалить draining-членов после переноса (данные перенесены, флаг снят) | члены остались в группе со статусом draining |
удалить вручную повторным сохранением группы | данные целы |
#INFO_KLVD_REBALANCE_WATCH_006 |
INFO | drain(!) отменён (админ остановил задачу / вернул узлы) — draining→active(!), узлы остаются | информационное | — | — |
#INFO_KLVD_REBALANCE_WATCH_007 |
INFO | drain(!) завершён — draining-члены удалены, узлы можно безопасно отключить | информационное | — | — |
#ERROR_KLVD_STORAGE_CIPHER_ROTATE_001 |
ERROR | не создана дочерняя задача ротации шифрования | ротация не запущена | проверить планировщик | — |
#WARN_KLVD_STORAGE_CIPHER_ROTATE_002 |
WARNING | ротация шифрования: невалидные аргументы (нулевой или совпадающий ключ) | ротация не выполняется | проверить параметры ротации (ключи) | — |
#ERROR_KLVD_STORAGE_CIPHER_ROTATE_003 |
ERROR | не удалось построить шифр старого/нового ключа | ротация прерывается | проверить секрет кластера и версию ключа | — |
#ERROR_KLVD_STORAGE_CIPHER_ROTATE_004 |
ERROR | не найдена запись чанка при ротации | чанк пропущен (failed++) |
проверить SQLite-базу хранилища | данные не теряются |
#WARN_KLVD_STORAGE_CIPHER_ROTATE_005 |
WARNING | файл чанка отсутствует на диске при ротации | чанк пропущен | проверить целостность storage(!); запустить deep-health | запись-сирота в БД |
#ERROR_KLVD_STORAGE_CIPHER_ROTATE_006 |
ERROR | не удалось открыть файл чанка для чтения | чанк пропущен | проверить права/диск | — |
#ERROR_KLVD_STORAGE_CIPHER_ROTATE_007 |
ERROR | не удалось расшифровать чанк старым ключом | чанк пропущен | проверить секрет/версию ключа; чанк мог быть уже перешифрован | — |
#ERROR_KLVD_STORAGE_CIPHER_ROTATE_008 / _009 |
ERROR | не удалось создать/записать memfd для перешифрованного чанка (Linux) |
чанк пропущен | проверить лимиты ОС | — |
#ERROR_KLVD_STORAGE_CIPHER_ROTATE_010 |
ERROR | не удалось записать temp-файл ciphertext (не-Linux fallback) | чанк пропущен | проверить права/место в каталоге хранилища | — |
#ERROR_KLVD_STORAGE_CIPHER_ROTATE_011 |
ERROR | storage(!)-движок не сохранил перешифрованный чанк | чанк пропущен; старый файл+БД целы | проверить storage(!) | данные не теряются |
#ERROR_KLVD_STORAGE_CIPHER_ROTATE_012 |
ERROR | не удалось обновить запись чанка в БД | чанк пропущен; остался orphan-файл | проверить SQLite-базу хранилища | данные не теряются (crash-safe) |
#ERROR_KLVD_STORAGE_CIPHER_ROTATE_013 / _014 |
ERROR | исключение при ротации чанка / всей ротации | обработка продолжается / ротация прервана | проверить детали в тексте; перезапустить ротацию | — |
#ERROR_KLVD_STORAGE_002 / _003 / _004 |
ERROR | сломанный JWT / недостаточно прав / нет JWT на запрос чанка | запрос отклонён | проверить авторизацию между узлами (секрет кластера) | — |
#ERROR_KLVD_STORAGE_030 |
ERROR | расшифровка провалена / не создан temp-файл | чанк не отдаётся | проверить место в /tmp, ключ шифрования |
клиенту возвращается E_FILE_CREATE_ERROR |
#ERROR_KLVD_STORAGE_033…036 |
ERROR | не удалось создать/записать файл в памяти (memfd) |
чанк не сохранён/не отдаётся | проверить лимиты ОС | — |
#ERROR_KLVD_STORAGE_006…008 |
ERROR | ошибка GET чанка (транспорт / HTTP / исключение) | чанк не получен | проверить сетевую доступность storage(!)-узла | — |
#ERROR_KLVD_STORAGE_009 / _012 |
ERROR | put_data_dedup: плохой размер блока / провал |
данные не сохранены | — | — |
#ERROR_KLVD_STORAGE_020…023 |
ERROR | аномалия / движок / БД / SQLite при сохранении файла | файл не сохранён | проверить storage(!), SQLite-базу хранилища, БД | — |
#ERROR_KLVD_STORAGE_024…028 |
ERROR | insert/update chunk (SQLite) / закрытие sqlite провалены | — | проверить SQLite-базу хранилища | — |
#ERROR_KLVD_STORAGE_BULK_001…003 |
ERROR | bulk-GET: транспорт / HTTP / исключение | массовое чтение не выполнено | проверить доступность | — |
#ERROR_KLVD_LIFECYCLE_001 / _003 / _004 |
ERROR | enter/clear rebalance(!) / set_emergency провалены | статус группы не изменён | проверить БД | — |
#ERROR_KLVD_GROUP_SETTINGS_001 |
ERROR | сохранение настроек группы провалено | настройки не сохранены | повторить; проверить БД | — |
#WARN_KLVD_GROUP_SETTINGS_001 |
WARNING | загрузка настроек группы провалена | используются значения по умолчанию | — | — |
#WARN_KLVD_RESOLVER_001 |
WARNING | группа в аварийном режиме — записи пропускаются | новые письма не пишутся в группу | устранить аварию группы (см. {{ССЫЛКА:install.storage-overview | Хранилище}}) |
#WARN_KLVD_STORAGE_STATS_001 |
WARNING | чтение статистики хранилища провалено | статистика показывает нули | — | — |
#WARN_KLVD_STORAGE_TRAVEL_001 |
WARNING | append в журнал перемещений провалено | некритично | — | — |
#WARN_KLVD_STORAGE_INIT_001 |
WARNING | путь хранилища не доступен для записи | роль хранения не сможет писать | проверить права на каталог | — |
#INFO_KLVD_STORAGE_TLS_001 |
INFO | получен сертификат TLS для хранилища из базы | информационное | — | — |
Коды
#ERROR_KLVD_STORAGE_CIPHER_ROTATE_001…014относятся к ротации ключа шифрования хранилища (перешифрование чанков). Эта операция crash-safe: при сбое отдельного чанка старый файл и запись БД остаются целы, данные не теряются — может остаться только orphan-файл.
Связанные материалы
- {{ССЫЛКА:reference.errors-index|Коды ошибок}}
Навигация по книге
- Следующая статья: {{ССЫЛКА:reference.errors-smtp|Коды ошибок: SMTP}}